System Outage
Incident Report for Teckro
Resolved
We are pleased to inform you that the recent outage affecting our platform has been resolved. Our team has identified and addressed the issue, and all services are now operating normally.

We will continue to monitor the situation to ensure stability.
Posted Nov 14, 2024 - 09:56 UTC
Investigating
We are currently experiencing an unexpected outage affecting our platform. Our technical team is actively working to identify and resolve the issue. We understand the inconvenience this may cause and are committed to restoring full service as quickly as possible.
Posted Nov 14, 2024 - 09:35 UTC
This incident affected: Teckro Mobile Application and Teckro Web Application.